YC Yc.W home Systems · C++ · AI Infrastructure
Database · Note

MySQL 安装、卸载与运行

Explore all Database notes →

背景

Ubuntu 18.04.5操作系统,安装与卸载MySQL数据库。

安装MySQL

终端sudo apt install mysql-server

注意:默认安装源上的版本

卸载MySQL

终端sudo apt autoremove --purge mysql-server

终端sudo apt remove mysql-server

终端sudo apt autoremove mysql-server

终端sudo apt remove mysql-common

终端sudo apt autoremove

终端sudo apt autoclean

MySQL-Server 5.7.31

  • 默认root密码为空,可通过error.log文件查看。终端sudo vim /var/log/mysql/error.log

  • 登录,终端mysql -u root -p

  • 启动服务,终端sudo service mysql start 或终端sudo systemctl start mysql.service

  • 修改密码,登录mysql后,终端ALTER USER 'root'@'localhost' IDENTIFIED WITH mysql_native_password BY 'new_password'; ,然后刷新权限,终端FLUSH PRIVILEGES;

  • show databases;:显示当前数据库
  • use database-name:使用database-name数据库
    • source xx.sql
  • CREATE DATABASE database-name;:创建database-name数据库
  • mysql -u root -p database-name < xxx.sql: 向database-name 数据库导入sql

Mysql 配置文件

  • /etc/mysql

其他问题

登录报错

error:1130

原因:没有远程连接权限。

方法: - mysql -u root -p - show databases; - use mysql - select Host, User from user; - update user set Host='%' where User='root'; - FLUSH PRIVILEGES;

启动失败,su: warning: cannot change directory to /nonexistent: No such file or directory

原因:一般是mysql服务器异常关机导致

方法:

sudo service mysql stop
sudo usermod -d /var/lib/mysql mysql
sudo service mysql start

← Previous 通用方式实现Map

Next → Navicat